Fossil Forum

Does the rss feed work for forum's?

Does the rss feed work for forum's?

Does the rss feed work for forum's?

(1) By anonymous on 2018-07-31 16:40:05 [link] [source]

IMO forums are a poor replacement for mailing lists especially if you are using a real mail client (and not some web based clients).

However that being said, are new threads and updates to threads included in the rss feed for fossil. That's probably the only way I will be able to continue to follow fossil.

(2) By Richard Hipp (drh) on 2018-07-31 16:45:57 in reply to 1 [link] [source]

I haven't tried it. Because of the way the forum is implemented, it probably does work without any changes. Please try it and report back.

(3) By smd (scottdoctor) on 2018-07-31 16:49:40 in reply to 2 [link] [source]

I turned on the email option to notify me of posts. I did receive an email that a post was made which requires clicking a link to read the post.

What about putting the text of that post into the email?

Doing such would effectively simulate the mailing list and not require bouncing back and forth from my email program to the browser.

(4.1) By Dan Barbarito (danbarbarito) on 2018-07-31 16:57:07 edited from 4.0 in reply to 2 [link] [source]

/timeline.rss is giving me just a blank white page. Is the new forum stuff making that page crash?

(5) By Richard Hipp (drh) on 2018-07-31 16:55:48 in reply to 3 [link] [source]

> What about putting the text of that post into the email?

That is something that is proposed. Recognize, though, that this will require some compromises. As the forum message text is render as HTML, we need one of the following two things:

  1. We need a mechanism to convert messages to text/plain from text/markdown and/or text/x-fossil-wiki. Or, perhaps just a single text/html to text/plain convertor, recognizing that any wiki-to-text or html-to-text conversion will inherently be less than perfect. Or..
  1. We need to start sending the alert emails as HTML.

Which of these two poisons do you prefer :-)

FWIW, I think option (2) will be technically easier to pull off.

(6) By Richard Hipp (drh) on 2018-07-31 16:59:53 in reply to 4.0 [link] [source]

> Is the new forum stuff making that page crash?

Dunno. Maybe. Can you debug it for me? I have given clone permission to your specific login (danbarbarito) so that you should be able to clone this forumtest1 repository. Do so. Compile the latest check-in from the forum-v2 branch, and run it on your local machine to see if you can catch it in a crash. Let me know if you need further debugging guidance.

I have on my to-do list a note to write up a debugging-howto for Fossil. But other issues have priority right now.

(7) By Dan Barbarito (danbarbarito) on 2018-07-31 17:10:54 in reply to 6 [link] [source]

Yep I can do that. I'm actually having trouble cloning the repo though. Well, I can clone it down but when I open it there is only one branch (trunk) with no content in it. I passed the --private flag to the clone command and it says I don't have permission to clone private content.

(8) By smd (scottdoctor) on 2018-07-31 17:11:48 in reply to 5 [link] [source]

Loss of the formatting may un-pretty the text a bit, but the user can just click the link to view formatted text in the forum.

I have no problem with receiving as html. But plain text does not confuzzle searches when look for a long ago post.

With the text in the email I can quickly decide if I have any interest or to just move on. If a few dozen posts are made, I have to sort out what goes with what and bounce back and forth alot. If multiple topics are getting posts...

(9) By ㎝ (_cm) on 2018-07-31 17:12:57 in reply to 5 [link] [source]

whi not just use the original textual source of the post, the one you get when you edit it?

(10) By ㎝ (_cm) on 2018-07-31 17:16:02 in reply to 5 [link] [source]

can we have the title of the post as the Subject: line of the mail?
that way, a smart MUA can thread the updates into topics.

(11) By Richard Hipp (drh) on 2018-07-31 17:20:10 in reply to 7 [link] [source]

The forumtest1 repository contains no check-ins. It only has these forum threads. So do this:

fossil open forumtest1.fossil
fossil ui

That should bring up a browser showing the forum.

For debugging, construct the RSS HTTP request in a file named "r1.txt". You can maybe capture a real HTTP request by running "fossil ui --httptrace", pointing your RSS reader to localhost:8080, stopping fossil, then looking at the "httplog-*.txt" files that were left behind.

Once you have an HTTP request, start Fossil in a debugger:

gdb fossil

Then do this:

run test-http <r1.txt

(12) By Dan Barbarito (danbarbarito) on 2018-07-31 17:50:58 in reply to 11 [link] [source]

Ok I will try that in a bit. I also have some other stuff on my plate but when that's done I'll let you know how the debugging goes.

(13) By Shal Farley (Shal) on 2018-07-31 17:54:12 in reply to 5 [link] [source]

I'd prefer text/HTML in the notification for either of the markups, but posts made in plain text I'd prefer a text/plain notification.

Unless maintaining two styles of notification body is bothersome.

(14) By Shal Farley (Shal) on 2018-07-31 17:56:52 in reply to 10 [link] [source]


(15) By Dan Barbarito (danbarbarito) on 2018-07-31 18:34:46 in reply to 11 [link] [source]

The /timeline.rss page is working locally which is strange. I tried to reproduce the issue by building various versions of Fossil but every version I tried worked. I thought my browser might have been acting funny or something but here is the HTTP response for the page:


HTTP/1.1 200 OK Cache-Control: max-age=0 Content-Encoding: gzip Content-Length: 20 Content-Type: text/html; charset=utf-8 ETag: Vary: Accept-Encoding X-Frame-Options: SAMEORIGIN

(16.1) By sean (jungleboogie) on 2018-07-31 19:31:07 edited from 16.0 in reply to 15 [link] [source]

Using curl on the hosted site, I see the content-length is 0:

> GET /forumtest1/timeline.rss HTTP/1.1
> Host:
> User-Agent: curl/7.61.1-DEV
> Accept: */*
< HTTP/1.1 200 OK
< ETag:
< Cache-Control: max-age=0
< X-Frame-Options: SAMEORIGIN
< Content-Type: text/html; charset=utf-8
< Content-Length: 0
* Connection #0 to host left intact

(17) By Richard Hipp (drh) on 2018-07-31 18:56:36 in reply to 15 [link] [source]

The code that does this is all in the "rss.c" source file. I suggest using the "fossil test-http" trick after setting a breakpoint on the "page_timeline_rss" function and single-step to see what is happening.

I don't really understand RSS. Do we need a separate page (/forum.rss) for a Forum-specific RSS?

(18) By Dan Barbarito (danbarbarito) on 2018-07-31 19:07:01 in reply to 17 [source]

Well what I'm saying is is that there are no crashes or anything on my end. The /timeline.rss page is working as intended when I just run "fossil ui" on the forumtest1 repository locally on my machine. I see all of the forum posts in the feed. It's only when I visit the hosted repositories /timeline.rss page ( where I get the blank page.

(19) By Richard Hipp (drh) on 2018-07-31 19:36:32 in reply to 18 [link] [source]

OK. That is a clue, actually. When you run it locally, you are probably running with "Setup" privilege, which means you can do anything. But on the system, you only have g.perm.WrForum. I think I need to add some additional permission checks to the rss.c file to deal with this. A quick glance suggests other changes are needed too. Shouldn't be too much trouble to fix - except I have the code all taken apart at the moment fixing something different, so I will need to get to this a little later. I'll come back and ask you to test it then.

(20) By Dan Barbarito (danbarbarito) on 2018-07-31 19:39:57 in reply to 19 [link] [source]

Ah ok that makes sense. Sure, whenever you need help testing anything feel free to reach out.

(21) By Richard Hipp (drh) on 2018-08-07 00:28:59 in reply to 10 [link] [source]

I have written the code that will (hopefully) make this work. This reply is my first test of the new feature on the test server. We'll see how well it works.

(22) By Richard Hipp (drh) on 2018-08-07 00:31:01 in reply to 21 [link] [source]

It seemed to work ok for me. :-)

Y'all, please see if you can break it....

(23) By sean (jungleboogie) on 2018-08-07 02:29:04 in reply to 22 [link] [source]

I also received the full email.

(24.1) By sean (jungleboogie) on 2018-08-07 02:32:12 edited from 24.0 in reply to 22 [link] [source]


(25) By sean (jungleboogie) on 2018-08-07 02:48:05 in reply to 24.1 [link] [source]

Deleted emails don't indicate they were deleted in the email message.

Forum post by jungleboogie on 2018-08-07 02:32:12