Fossil Forum

Forum
Login

Can't set email-send-command to "sendmail -t"

By wyoung on 2018-08-12 00:19:26

On a repo with email already set up and working, you can see this with:

  1. fossil unset email-send-command
  2. Go to Admin → Notification and click the "Apply Changes" button.

This should set this attribute to the default, "sendmail -t", but it doesn't. You can double-check it by enabling admin-log and clicking the button again, showing that it doesn't get into the if test within entry_attribute.

To get this settings change to stick, you have to change that input field to some other value, apply the change, then change it back, and re-apply it.

If you use your browser's developer tools to inspect the POST parameters, you'll see that ecmd is being sent, regardless of field contents. That means the if shouldn't be skipped due to the zQ test: P("ecmd") should be returning a nonzero pointer.

I've tried to debug it, but I got lost trying to figure out how Fossil processes an HTTP POST.